Eliminar Datastore inactivo o huerfano.

Buenas,

Hoy me encontrado con una situación de estas que parece que te va a costar 5 minutos y acabas echando espuma por la boca. Debido a un cambio de NAS y no seguir correctamente el procedimiento de desmontar y eliminar el datastore, a acabado por avinagrarme la tarde y perder bastante tiempo.

Unos de los Datastores se me ha quedado en estado inactivo en uno de los ESXI.

1

Cuando le he dado a desmontar parecía que todo iba bien.

2

Me ha saltado el siguiente error.

3

He probado a eliminarlo y mas de lo mismo, el datastore seguía ahí.

4

Y aquí ha empezado el calvario, enumero las pruebas que he hecho:

– reiniciar agentes mediante /etc/init.d/hostd restart y /etc/init.d/vpxa restart

– Intentado con PowerCLI

– Intentado con ESXCLI

– desmontarlo o eliminarlo conectándome directamente al ESXI con el vSphere Client

Cada vez que probaba cada una de estas opciones, rescaneaba los Datastores para ver si sonaba la trompeta y desaparecía el maldito datastore.

Ya no me quedaba mas que reiniciar el host, pero no había vMotion y el otro ESXI no tenían recursos suficientes para albergar todas las VMs.

Así que una vez que ya estaba desquiciado, tirando balones fuera y a por uvas, se me ocurrió probar directamente desde la consola DCUI Direct Console User Interface (gracias por tu post Luis Aitor). Te conectas por SSH al ESXI y escribes dcui.

6

Y accedes a la ILO de los pobres.

7

Aqui todos los pasos son como si estarías delante del ESXI.

8

Entras a Troubleshooting Mode Options.

9

Y reinicias los management agents.

10

Solucionado, mano de santo, desaparece el datastore y agrego el de la nueva NAS. Si no me llega a funcionar esto, era capaz de probar a borrar el datastore con la goma del paint.

11

Saludos y espero que os sirva.

Gorka Izquierdo